question about camera alert

hfranck
Posts: 9
Joined: Tue Dec 02, 2014 6:44 pm

question about camera alert

Postby hfranck » Wed Dec 03, 2014 3:30 pm

Hi,

I am doing a cgi php and already I can get the id of the camera. I would like to receive a frame image. What is the name of the post grab image field?
Attachments
Alert_Call_Url.png
Alert Call Url configuration for my php script
Alert_Call_Url.png (12.99 KiB) Viewed 1706 times

User avatar
sporn
Posts: 1689
Joined: Sat Mar 29, 2014 4:21 am
Contact:

Re: question about camera alert

Postby sporn » Thu Dec 04, 2014 1:44 am

It doesn't have a name, it's in the files collection

http://stackoverflow.com/questions/1693 ... hp-request

hfranck
Posts: 9
Joined: Tue Dec 02, 2014 6:44 pm

Re: question about camera alert

Postby hfranck » Thu Dec 04, 2014 1:25 pm

Thanks for the feedback.

I tested all field arrays returned by php / apache like:

$ _FILES, $ _REQUEST, $ POST, $ _SERVER ['QUERY_STRING']

and I did not find any data unless the camera ID.

You would have some sample script done in any programming language showing how to get the frame grab?

User avatar
sporn
Posts: 1689
Joined: Sat Mar 29, 2014 4:21 am
Contact:

Re: question about camera alert

Postby sporn » Tue Dec 09, 2014 8:02 am

In ASP.NET I can look at the Request.Files object

Request.Files[0]
{System.Web.HttpPostedFile}
_contentType: "image/jpeg"
_filename: "grab.jpg"
_stream: {System.Web.HttpInputStream}
ContentLength: 29817
ContentType: "image/jpeg"
FileName: "grab.jpg"
InputStream: {System.Web.HttpInputStream}

hfranck
Posts: 9
Joined: Tue Dec 02, 2014 6:44 pm

Re: question about camera alert

Postby hfranck » Tue Dec 09, 2014 6:18 pm

ok, now worked well.

Thank you.

Luko81
Posts: 2
Joined: Mon Jan 15, 2018 5:03 pm

Re: question about camera alert

Postby Luko81 » Mon Jan 15, 2018 6:38 pm

hey guys,

how do I get this to work now with the latest version? "Post grab" seems to be "Upload Image" now right? Can I still access it in the "$ _FILES" variable? And what about nodejs (express server)? any clues?

Thank you guys.


Return to “System Setups”

Who is online

Users browsing this forum: No registered users and 1 guest